missing qt and wxt terminals from gnuplot 5.2.5

qt and wxt terms are missing from gnuplot 5.2.5 installation
X11 terminal gives a semi black graphics and is missing menu bar.
Please advice how to proceed to add qt terminal.
sudo apt-get command installs 5.0.5, which is 2016 version.

Current version is 5.2.5. When compiled in Ubuntu Linux diid not have this issue.


Affordable-Laptop 06-12-18, 11:45 a.m. ranipv

Could you please share screenshots?

How do you use to install qt and wxt terms on Ubuntu? Please share the steps so that I can reproduce them on my end.

06-12-18, 12:01 p.m. Srikant


screenshot from 5.0.5 where qt / wxt is present

06-12-18, 12:56 p.m. ranipv


from 5.2.5 version has only X11 / xterm working. qt / wxt terminals are missing

06-12-18, 12:59 p.m. ranipv


Try installing the following packages on your laptop:

  • sudo apt install -y libwxgtk3.0-dev qtbase5-dev libqt5svg5-dev
  • Now, download the gnuplot source file, extract and change directory to gnuplot-5.2.5
  • TERMLIBS="-lX11" ./configure --with-qt=qt5 --with-wx-single-threaded
  • make
  • make check
  • make install

That's all, the qt and wx terminal both should now work with the latest Gnuplot.

06-12-18, 5:55 p.m. Srikant


Thank you very much. Qt terminal works now.

08-12-18, 10:29 a.m. ranipv


To add, to clear screen, the universahl ctrl-L works from konsole.

Though, it changes to ctrl shift K in gnuplot prompt for 5.2.5

Can this be reassigned to ctrl - L for uniformity?

14-12-18, 5:15 p.m. ranipv
I have tried ctrl -L on compiled versions on both Debian-9 and Ubuntu-18.04, both occasions they failed. 
There is also no official documentation on the clear screen which I can refer to. 
In the default 5.0.5 version available in Debian and Ubuntu repositories both "ctrl - L" and "ctrl shift K" clears the gnuplot prompt. 

I have tried backporting 5.2.5 to stretch but they have got unmet dependencies. 
So right now I see the following options:
1) Using "ctrl shift K" to clear screen
2) Using "system 'clear'" command on the prompt to clear the screen
3) Using distribution provided gnuplot which is 5.0.5 (unless you want some specific features in 5.2, this version should work fine too)
4) Find a way to compile gnuplot with the support of x11 bindings (I will check this)

15-12-18, 7:53 p.m. Srikant

Login to add comment

Log-in to answer to this question.