Problem with WiFi connection

The problem is wifi keeps on connecting and disconnecting. It's always unpredictable. Whether on mobile phone hotspot or on institute's wifi, only my laptop faces this problem of intermittent connectivity. All other devices (phones, laptops) of my classmates connected to the same network (even on mobile hotspot) shows seamless connectivity. Only my Thinbook 1310 keeps on connecting and disconnecting again n again. When it would get connected n when it will disconnect is always unpredictable. That's why as per my opinion, the problem lies with the hardware n not software

The access point of the Wifi just outside our room in the hostel. And I face this problem everywhere, in the class, in the hostel, in the library, in the dining hall. And everwhere, I see other people sitting just besides me working on their laptops without any problem. Please let me know what to do in this case. (When I started writing this question, I begun on my Thinbook 1310, and just after few minutes the Wifi disconnected. So submitting this on my phone which is connected to the same Wifi network)

Affordable-Laptop 15-11-18, 12:26 p.m. Vikram

I understand, it really gets annoying. I have had a similar issue with my other laptop. But fortunately, in your case, we know that the
RDP wifi driver is fine as it works with other users.
Nevertheless, please try the following steps:
Test I:
1) Delete all the wifi connections (saved/ unsaved)
2) Try reconnecting the strongest wifi AP(access point) (try to be as close as possible to the network)

Test II:
1) Try USB tethering using your Android phone. The USB tethering should
create a virtual LAN connection with your phone and laptop. This test will confirm if this issue is caused by
OS or the driver. In most cases, your internet should work using this method.

Test III:
1) If both of the above fails. Try updating the Kernel. We have recently added a new Kernel which shows the correct
wifi signal strength.
To get the update, use the "Test II" setup (assuming it works for you). Then try the following:
a) Open konsole (terminal) application
b) sudo apt update && sudo apt install -y linux-image-4.19.1-iitb

Restart your laptop and test your connection.

15-11-18, 12:44 p.m. Srikant
Thanks for the reply.

Test I-
I have executed this several times earlier and it has failed always.
Test II-
I tried USB tethering just now. It is working fine so far. But what does it indicate? Where does the issue lie? In the OS or the driver?

15-11-18, 1:04 p.m. Vikram
It lies with the network module, mostly with wifi.

Try the 3rd test.

15-11-18, 1:15 p.m. Srikant
Command line option 'l' [from -ylinux-image-4.19.1-iitb] is not understood in combination with the other options.

this is the error msg. plz help

15-11-18, 2:07 p.m. Vikram
The editor was applying some formatting rules. Try now. 

sudo apt update && sudo apt install -y  linux-image-4.19.1-iitb

15-11-18, 2:15 p.m. Srikant
I hope this fixed your issue.

16-11-18, 9:03 a.m. Srikant
No. Yesterday I had connected my mobile phone to the institute's wifi, and then I had tethered it to the laptop. Yesterday it worked. But today I found that if my phone is connected to mobile data connection, the laptop is though getting connected to the mobile hotspot, through wifi, but no webpage getting opened in the browser. The error is - "Server not found". Then I tried tethering. But unlike yesterday, my phone is not on connected to wifi but to the mobile data connection, again the laptop is showing that - the connection is activited. But no webpage is getting opened. Erroe is- "server not found"

16-11-18, 10:50 a.m. Vikram
I hope you applied the said update. 
Your original issue seems to be resolved, is it? You now seems to have a reliable wifi connectivity. 

The "server not found" issue is because of your mobile-data hotspot, it isn't sharing the DNS to the tethered device, though your wifi+wifi tethering shares the proper nameservers(DNS). Try connecting to a real wifi access point(WAP). 

16-11-18, 11:02 a.m. Srikant
I have applied the said update yesterday only.

Can you please guide me, what to do to make my mobile phone share the DNS? I am using Moto G5 plus

16-11-18, 11:18 a.m. Vikram
Now again the laptop is not connecting to the phone's hotspot. A window called 'KDE Wallet Service' is opening. Asking for password.

16-11-18, 11:24 a.m. Vikram
This is uncommon. Just enter your user password to unlock 'wallet' services. You can open the "kde wallet" and disable the wallet service. 

Also, for your phone mobile-data hotspot you need to find the DNS entries and paste them in wifi connection DNS entries of your laptop(edit the existing hotspot connection). This is very uncommon as in most cases mobile-data tethering works. 

16-11-18, 11:37 a.m. Srikant
I put the password in KDE wallet services. After that the connection got established. I surfed the internet for a while.  "Server not found" error did not appear. I tried both tethering and hotspot.

Then I was doing some other work for some time. So I disconnected the phone from laptop. Now again I started working on laptop. The laptop got connected to mobile hotspot. And now again 'server not found' appearing.

Just now I saw your comment regarding how to put DNS entries. But I have not executed it till now. Then how was I able to surf the internet for a while ? And why I am not able to surf again?

16-11-18, 12:07 p.m. Vikram
This could be due to your phone's poor data reception? If not, the hotspot implementation has some bug which isn't sharing the DNS sometimes. It is difficult to debug beyond this point remotely. 

As the wifi is working with regular WAP, I wouldn't blame it on the Debian driver either. 

16-11-18, 12:19 p.m. Srikant
Thank you for your help. Whom to contact now if I want to show my laptop in person? Where is the service center in Mumbai?

16-11-18, 12:26 p.m. Vikram
You can contact RDP and find out their authorized service centers near your location. 

16-11-18, 12:33 p.m. Srikant
Ok. Thanks

16-11-18, 12:37 p.m. Vikram

Login to add comment


Also in the settings is an option to Update Driver. Use the ethnernet connection tto let Windows wander round the Net to find the right driver.

07-10-19, 12:46 p.m. duxaqusu

Motivated by the hit Street Robbery series - Grand Theft Auto (GTA), Gameloft has fostered an appealing third individual shooter called Gangstar Vegas: World of Crime Mod Apk limitless cash, open VIP key Gangstar Vegas APK can be considered as a duplicate of the GTA blockbuster with an advanced setting in Las Vegas, Nevada. The story rotates around Jason Malone - a talented MMA warrior who is the objective of Frank Veliano after a success. Like GTA, Gangstar Vegas likewise joins hustling scenes with TPS shooting in the open world to make a unique encounter for players! As Jason Malone, you abruptly become the most pursued man in the city. In this frightening wrongdoing city, you must have your weapon prepared consistently to manage the posses! Gangstar Vegas is a smooth mix of hustling, shooting, robot battling, managing zombies, looters and numerous other energizing activities to be found during the game!
26-11-21, 12:16 p.m. adreaqueency

Follow the instructions on google, word counter online if not, call the operator directly
17-01-22, 8:02 a.m. pipahaha

Thank you for sharing. You can try rokkr url allows users to search for live streams of TV channels, movies, sports and much more.
24-01-22, 2:50 p.m. JennyLawrence

i have faced the same issue with my laptop.
23-02-22, 11:13 a.m. vocek52719

The same problem occurs to me with my gaming laptop.
04-06-22, 12:21 a.m. vocek52719

Hey, action lover, do you want to play most popular action game Stumble Guys MOD APK in your mobile, then try this out with unlimited money?
08-08-22, 12:35 a.m. vishl99

Log-in to answer to this question.