0
eSim-2.3 installation issue on LInux Mint 21 Vanessa

Hello,

Following the Installation Instructions, I launched:

$ ./install-eSim.sh --install

Everything seemed to go smoothly until I got the pictured error.

Can you please help?

Thnaks in advance


eSim 27-11-22, 12:37 a.m. Andre_archi
0
Dear André,
Thank You for trying the OpenSource software eSim.
Please run the following command in the terminal:
$ pip3 install --upgrade https://github.com/hdl/pyhdlparser/tarball/master
And then continue running the installation script again:
$ ./install-eSim.sh --install
Please feel free to contact us again in case of any more doubts.

You may even mail at contact-esim@fossee.in
Regards,
Sumanto Kar
eSim Team
FOSSEE
29-11-22, 11:09 a.m. Sumanto


0
Dear Sumanto, Thanks for your help. Indeed, doing this pip3 install was an improvement as the installation went further. However, I assume there is an issue with the Kicad version 4 seemingly implemented in eSim, because the corresponding PPA does not support Ubuntu Jammy (22.04). See below screenshot. I guess I might have to wait for next eSim version. Best regards. André
03-12-22, 8:05 p.m. Andre_archi

Dear Andre,

Yes, you are right. eSim uses Kicad version 4 and the corresponding PPA is not supported by Ubuntu. You may try some of the links over the internet to solve the issue. Something like this:
https://askubuntu.com/questions/1420531/cannot-add-ppa-this-ppa-does-not-support-jammy-when-installing-sublime-t

Also, the KiCad 4.0.7 can be installed manually from here: https://github.com/KiCad/kicad-library/releases/tag/4.0.7

Let us know if the above thing works.

We are on it to find the solution for the above problem to port everything to Kicad-5 or some other solution for the next release of eSim. We are also checking the compatibility for the same.

Any help/suggestion in this regard is highly appreciated. Thanks a  lot in Advance!

Thanks & Regards, 
Sumanto Kar
eSim Team

 


03-12-22, 11:06 p.m. Sumanto

Login to add comment


0
Dear Sumanto, Thanks again for answering. I did not find yet a useful (for me...) info concerning the PPA isue. I will continue anyway. I also intend try a manual installation of KiCad 4.0.7 and will acknowledge you about the result. Best regards. André
06-12-22, 10:48 p.m. Andre_archi

Dear Andre,

Thanks for your reply. Actually, KiCad has quite recently removed the PPA for 4.0.7. So, we are trying to solve it as soon as possible by trying various workarounds. For now, the manual installation would be the best possible way. We are also trying to upgrade to KiCad 5 but also looking for compatibility. 

Please update us in case there is some update from your side. Thanks again.

Regards,
Sumanto Kar
eSim Team


09-12-22, 8:18 p.m. Sumanto

Login to add comment


Log-in to answer to this question.