snappyhexmesh fails in surface refinement stage

I am trying DTCHull case in OF V.2206 Version 2.0. while running snappyhexmesh after executing toposet and refinemesh i am getting an error as shown in uploaded picture. it gives a message like cell513214 of level 0 uses more then 8 points of equal or lower level. if anyone have come across such an issue please tell the way to rectify this issue.

is this because of non gradual refinement between two layers, please enlighten me with the solution

OpenFOAM 08-10-22, 11:46 a.m. MS321@
i am attaching the error message below please provide an answer, Regards MS321@.
08-10-22, 11:50 a.m. MS321@

Hi MS321, Could provide me with the list of commands that can reproduce this error?
10-10-22, 1:06 p.m. Aabhushan

commands in order of execution


this is the order i followed, please help me with a solution @Aabhushan if you ever come across such an error.




10-10-22, 2:42 p.m. MS321@

Hi MS321,

Make sure you are giving the "refineMeshDict -overwrite" command every time you are refining mesh. Also, this tutorial requires you to run a series of toposet and refineMesh six times. Although it will work for just three times the mesh created will be very bad.

Aabhushan Regmi

11-10-22, 12:40 p.m. Aabhushan

Login to add comment

Thankyou Aabhushan Regmi for the reply I am still having trouble with the same error can you please give a suggestion for the above problem.
13-10-22, 5:02 a.m. MS321@

I am using OpenFOAM v9 and it's the exact same tutorial. It's working perfectly in mine. Give me some time I will try this in your OpenFOAM version and see if I can reproduce the error.

13-10-22, 11:29 a.m. Aabhushan

Login to add comment

Bro I am using DTMB 5415 not DTCHull. I create my one toposet cells and refine then if i run this snappy it gives me error. So that question what should be the criteria that we need to keep in mind when we choose the coordinates for topoSetdict. Regards Thankyou
13-10-22, 12:08 p.m. MS321@

*my own toposet not 'one toposet'
13-10-22, 12:09 p.m. MS321@

Snappyhexmesh failed snake io in the surface refinement stage. The mesh was too rough and the details were too small.
04-01-23, 3:14 p.m. lilycollins

The above problem can be solved by keeping defining the toposet little away from the ship. Keep some gaps in between each toposet entries. Even then you are getting the error just play with the gaps in between the toposet boxes. Thats how i solved this.
05-02-23, 5:42 p.m. MS321@

Insufficient surface resolution: If the surface resolution is too coarse, SnappyHexMesh might struggle to generate a suitable mesh. Increase the resolution of your input surface by adding more points or refining it with a surface remesher, if possible. This can help SnappyHexMesh create a better-quality mesh. FRP Bypass
04-07-23, 6:39 p.m. admin1re

Log-in to answer to this question.