0
"Abort" command in Scilab 6.0.0

Hey guys,

I have a problem with the "abort" command in Scilab 6.0.0... It does not seem to work properly: Whenever I have it in my code for stopping at a particular place (which I use quite frequently) the execution stops but within my variables-browser I don't see any results. They pop up when I type something in the console and press Enter, but I guess that is not how it is supposed to work? Furthermore, when I run the example code from the Scilab help the comman does not work at all:
a=2\nb=3\nabort // The execution will stop here.\nc=4   // c will not be defined
When executed, all three variables, a, b, and c are being defined...
Does anybody know how to deal with that??

EDIT: Hmm, now also in my script Scilab simply ignores the "abort" command... :/


Scilab 08-05-17, 2:38 p.m. Hackmet

Answers:

0

I tested the abort command, and it is working well in the context you have mentioned. Are you sure you are clearing variables after each run? If not, then that is the cause of your problem. If so, I will need to take a look at your code, if you can share it.

Regards.

08-05-17, 2:50 p.m. Sid11235


0

OK, I found an error within my script and the "abort"-command works again but only more or less... See for instance the following code:

clear;
A = 2;
B = 5;
abort;
C = 8;

Before I run the script in the freshly started Scilab I can use the Console normally - hence, If I write A = 2 and hit return it creates the variable and displays the value of A in the console window.

If I run the script I only see that it was performed but I do not see any new variables in the variable-browser. Only after, for instance, typing a 1 in the console window and hitting return I see that the script actually did something, as A and B are defined (C is not, as it is supposed to be).
However, now after having run the script I cannot use the Console-Window properly anymore.. I still can use it to define variables or perform calculations but the results are never displayed in the console. It is if every command I input would have the ";" at the end.... This is annoying, as only rebooting Scilab helps in that case..
Maybe if it helps, here is what the console displays upon Scilab-Startup:

Starte Ausfuehrung:
lade Startumgebung
START GUI Builder 4.0.1 for Scilab 6.0
Load macros
Load help
Type "guibuilder" to start the GUI

Start IPCV 1.0 for Scilab 6.0
Image Processing and Computer Vision Toolbox for Scilab
Copyright (C) - 2017 - Tan Chin Luh (Trity Technologies)
Find more information at http://scilabipcv.tritytech.com
Load macros
Load dependencies
Load gateways
Load help
Load demos

Thanks already for your help!!

09-05-17, 2:50 p.m. Hackmet


Log-in to answer to this question.