SnappyHexMesh Tutorial

I tried to run snappyHexMesh in the same way proposed by the Spoken-Tutorial. But I am getting the Error like this: snappyHexMesh: symbol lookup error: /home/suman/OpenFOAM/ThirdParty-v1612+/platforms/linux64GccDPInt32/lib/openmpi-system/libptscotcherrexit.so: undefined symbol: lam_mpi_comm_world Please let me know if you have a solution for it. Thank you very much. Regards, Ankur

OpenFOAM 01-04-17, 11:31 a.m. ankur_garg

Hey Ankur, That error means that you do not have the MPI library built properly or it is mis-configured. I would suggest you try to install OpenMPI by typing -

  • sudo apt-get install libopenmpi-dev

And then re-install OpenFOAM.

Please let me know if that works. Also, could you let me know your Operating System details?

01-04-17, 11:37 a.m. anmolsahoo
Hi Anmol,
I am new to OpenFOAM. This is the information, i have for now:
I am using OpenFoam - 16.12.
Ubuntu - 16.04.
I tried to install OpenMPI , it says like this:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libopenmpi-dev is already the newest version (1.10.2-8ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 229 not upgraded.

Let me know if something is missing.

Thank you very much.


01-04-17, 12:21 p.m. ankur_garg
It seems like your Third party libraries have not been built properly. Could you tell me how you installed OpenFOAM? By using the Ubuntu package manager or from source?

02-04-17, 8:58 p.m. anmolsahoo
From Source

02-04-17, 9:13 p.m. ankur_garg
Have you tried rebuilding your Third Party libraries, and let me know if it is still not working?

02-04-17, 9:19 p.m. anmolsahoo
I will try that tomorrow and let you know. Thank you so much!!

02-04-17, 9:20 p.m. ankur_garg
Hi Anmol,

I tried rebuilding the Third Party Libraries first by putting these commands in Terminal:
It said: Build Successful
I hope, It's fine?
After that, Again While I am trying to run snappyHexMesh, it gives me the Same Error.

03-04-17, 2:17 p.m. ankur_garg

It seems like you have conflicting versions of OpenMPI on your system. Could you copy-paste the output of these following commands -
mpiexec --version
mpirun --version
mpicc --version

03-04-17, 3:43 p.m. anmolsahoo
Hi Anmol,

Thank you for reverting back to me. These are the outputs from The Above three Commands:
mpiexec (OpenRTE) 1.10.2,
mpirun (Open MPI) 1.10.2,
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Thank you.


03-04-17, 3:48 p.m. ankur_garg
Could you tell me the ouput of -
echo $WM_MPLIB

03-04-17, 3:55 p.m. anmolsahoo

03-04-17, 3:57 p.m. ankur_garg
So, most of your settings seem in place and I am not able to reproduce the issue. As of now, I would suggest you try installing OpenFOAM 4.0 from the openfoam.org website and let me know if that works.

Meanwhile I will try to find out what the issue is with this.

03-04-17, 4:42 p.m. anmolsahoo
Oh. That's perfectly fine, Anmol. I will try with OpenFOAM 4.0 and let you know. Thank you so much!!

03-04-17, 4:47 p.m. ankur_garg

Login to add comment

Log-in to answer to this question.