Error in the ngspice simulation for the nghdl

The .model file is not being recognised by ngspice for simulation

The nghdl is creating the the circuit according to the .vhdl code but

only for my halfadder .vhdl design ghdl was invoked in ngspice but for my full adder .vhdl which i was testing, it is not getting recognised by ngspice and its says that .model is not recognised i don't know what i am doing wrong but i strongly feel that there is some problem with tool and there some issue which needs to be fixed

I even tried the already given nghdl example for the full adder .vhdl in esim folder but that also is showing the same error

I have spend 5 hours on this matter and still the tool won't work for just a simple full adder

eSim 21-05-21, 10:08 a.m. ReuelReuben
Hi Reuel, you should refer the Appendix section pertaining NGHDL in the user manual for this. From the looks of it, its a naming issue. Please go through the documentation carefully
01-06-21, 1:15 p.m. Saurabhb17

what you write is amazing, this knowledge helps me a lot in life, thank you for these wonderful things run 3
14-06-21, 10 a.m. pukaka

Thank you for the error updates online these are quite provoking. I hope through getting valuable sharing people are getting great help on your blog and fixing the problems. Keep going with your tremendous blog update on https://www.edugeeksclub.com/buy-thesis/ please do share more help.
15-10-22, 2:24 p.m. LeightonPatterson

Log-in to answer to this question.