1
Error in NGHDL

Hi

I'm getting an error when I try to upload a vhdl file in Ngspice Digital Model Creator where it says compilation terminated, FileNotFoundError : no such file or directory: 'ghd1/ghd1.cm' and closes immediately.


eSim 15-02-21, 4:34 p.m. Sudharshan
1
which OS version are you using? Are you able to run simulations of other circuits(analog in nature), if not please try. also try uploading some already provided examples in the nghdl/Examples/ folder
16-02-21, 10:09 a.m. Saurabhb17
I'm using Windows 10 64-bit I tried running few simulations and was pretty much successful and also uploaded a couple of vhdl samples provided in eSim software but I got the same error,I've posted the screenshot of the same below. I even checked for the eventsys header file in mingw64/x86_64-w64-mingw32/include directory.

16-02-21, 8:01 p.m. Sudharshan

perhaps you had mingw already installed in your PC before you installed eSim and now its creating path conflicts?


17-02-21, 12:31 a.m. Saurabhb17

You're right I had previously installed mingw for C programming stuff.

What do you think I should do now??

 


17-02-21, 9:27 a.m. Sudharshan

you can remove the other mingw if you don't need it anymore or set the path properly so that ngspice looks at the mingw present in eSim folder and not the one you had previously installed


17-02-21, 10:50 a.m. Saurabhb17

Thanks a lot it worked.


17-02-21, 1:36 p.m. Sudharshan

Login to add comment


Log-in to answer to this question.