0
Error while executing exec loader.sce

Hi,

I attended your workshop and I have followed all the installation guidelines which was on the scilab-arduino workshop webpage. It worked fine with the system I had that day which was Ubuntu 14.04. But now I am trying to do the same in another system Ubuntu 12.04 with the scilab-5.5.2 as well as default package of scilab in Ubuntu and I am getting the following error. Please help. There were few participants facing similar issue that day.

-->exec loader.sce
 
-->// This file is released under the 3-clause BSD license. See COPYING-BSD.
 
-->// Generated by builder.sce: Please, do not edit this file
 
 
-->try
--> getversion("scilab");
-->catch
--> error("Scilab 5.0 or more is required.");
-->end;
 
 
-->exec(get_absolute_file_path("loader.sce")+"etc/"+"arduino.start");
Warning : redefining function: startModule             . Use funcprot(0) to avoid this message

Start Arduino
\tLoad macros
\tLoad serial dll
Link failed for dynamic library '/home/trupti/Downloads/linux/src/libserial.so'.
An error occurred: /home/trupti/Downloads/linux/src/libserial.so: cannot open shared object file: No such file or directory
ial','status_serial','read_serial'],'c')
                                         !--error 236 
link: The shared archive was not loaded: (null)
at line      40 of exec file called by :    

at line      41 of function startModule called by :  
  arduinolib = startModule();
at line     114 of exec file called by :    
exec(get_absolute_file_path("loader.sce")+"etc/"+"arduino.start");
at line      10 of exec file called by :    
exec loader.sce


Scilab-Arduino 05-08-15, 8:28 p.m. kinitrupti

Answers:

0

Plz find the below link for the updated one.
https://drive.google.com/open?id=0B4mrKFv8PNbWfnFnNEtudENKNGZxZWViRURoNGw1X3ZyQzJYd0ZNV05fWUxteFliSW1SajQ

Execute loader.sce and if same error occurs , plz refer the troubleshoot.txt file.

06-08-15, 11:34 a.m. manas


0

Hi,


Thanks. It is working now.

08-08-15, 1:03 p.m. kinitrupti


Log-in to answer to this question.