File Browser without directories and files

I have a very strange problem. On my MacBook pro the Scilab File Browser shows all the files of the Documents directory. On my new iMac the Scilab File Browser doesn't show any file in the Documents directory.

I append a file with screenshots.

I hope, someone can help me.



Scilab 01-01-21, 11:23 p.m. RudiLehn
After an Big Sur update, the problem was solved.
04-02-21, 10:30 a.m. RudiLehn


I think this problem was resolved after the update!

If you still facing issues you can contact me on fmwa

13-03-22, 1:58 p.m. ayaanly

Big SUR fixed this. gbwa
17-05-22, 5:33 a.m. nirmalsingh

This issue has been fixed by the producer. Please restart your MacBook! capybara clicker
11-01-23, 3:20 p.m. thomasfrank

You can re-update Scilab File Browser, and I believe everything will be alright. eggy car
06-03-23, 7:27 a.m. drewbinsky

You can try the following
Check the permissions of the Documents directory: Make sure that the files in the Documents directory on your iMac have the appropriate permissions and allow Scilab to access them. You can try setting appropriate read and write permissions for the directory and files.
Refresh the File Browser: Try refreshing your view in the Scilab File Browser. Typically, you can refresh the file browser by clicking the Refresh button on the interface or by using a shortcut key (such as F5) to update the file directory.
Check Scilab's settings: Make sure the option to display files in the document directory is enabled in Settings in Scilab. Check Scilab's Preferences or Settings menu and look for options related to the File Browser.
Update Scilab version: If you are using an older version of Scilab, consider upgrading to the latest version. Newer versions usually fix some known problems and bugs and provide better compatibility.
Check logging or error messages: When the Scilab File Browser cannot display a file, it may provide some error messages or logging. See if Scilab provides any relevant information to help you determine the problem.
11-09-23, 11:13 a.m. wudier

Log-in to answer to this question.