0
devnagari fonts

Hi

Recnently I was able to install WPS office on my Debian Thinbook.

I can use wps office for editing/opening all word/excel/ppt files, except those with content in devnagari fonts.

How to address this?


Affordable-Laptop 30-09-20, 1:31 a.m. prarthjeet
1
We haven't tried WPS.
However, this might help. https://help.wps.com/articles/change-default-font-writer The devnagari fonts are already installed on the OS, WPS should locate at the right location.
30-09-20, 2:09 a.m. Srikant

If the OS comes loaded with devnagari fonts, how do I enable typing in devnagari fonts.

Is there any phonetic keyboard preloaded in OS?


30-09-20, 4 p.m. prarthjeet

My bad, it seems devanagari fonts are missing. 

You can install them through terminal by using(internet needed):
sudo apt install fonts-lohit-deva fonts-sahadeva fonts-nakula fonts-deva-extra fonts-samyak-deva

You can configure phonetic keyboard by "menu->search->ibus-configuration"


01-10-20, 9:59 a.m. Srikant

Thanks Srikant

I have installed the mentioned Devnagari fonts. Though the fonts seem installed, how to enable devnagari fonts for typing?

Also, couldn't locate "ibus-configuration" in search. 

 


06-10-20, 8:52 a.m. prarthjeet

The ibus-configuration should be preinstalled, if not, try the solution given here
https://wiki.debian.org/I18n/ibus


06-10-20, 10:50 a.m. Srikant

For some reason ibus-cnfiguration wasn't pre-installed in my debian system. Now installed it.

But now, when I open it for confugaration, it doesn't have any devnagari font / language listed in it. Though all the font mentioned above have been installed.

How should that be addressed?


10-10-20, 10:29 p.m. prarthjeet

In the ibus-configuration you should find
input method -> select language from the dropdown and Add

https://ostechnix.com/how-to-setup-multilingual-input-method-on-ubuntu/


12-10-20, 9:14 a.m. Srikant

Login to add comment


Log-in to answer to this question.