0
error while running a solver

Hi all, I am solving flow past a cylinder problem using pisoFoam. When i run the solver i get the following message: subhankar@subhankar-Lenovo-G50-70:~/OpenFOAM/subhankar-3.0.1/run/tutorials/incompressible/pisoFoam/new$ pisoFoam /*---------------------------------------------------------------------------*\ | ========= | | | \\ / F ield | OpenFOAM: The Open Source CFD Toolbox | | \\ / O peration | Version: 3.0.1 | | \\ / A nd | Web: www.OpenFOAM.org | | \\/ M anipulation | | \*---------------------------------------------------------------------------*/ Build : 3.0.1-d8a290b55d28 Exec : pisoFoam Date : Oct 14 2016 Time : 04:43:29 Host : "subhankar-Lenovo-G50-70" PID : 9975 Case : /home/subhankar/OpenFOAM/subhankar-3.0.1/run/tutorials/incompressible/pisoFoam/new nProcs : 1 sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE). fileModificationChecking : Monitoring run-time modified files using timeStampMaster allowSystemOperations : Allowing user-supplied system call operations // * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * // Create time Create mesh for time = 0 PISO: Operating solver in PISO mode Reading field p Reading field U Reading/calculating face flux field phi Selecting incompressible transport model Newtonian Selecting turbulence model type laminar No MRF models present No finite volume options present Starting time loop forces forces: Not including porosity effects forceCoeffs forceCoeffs: Not including porosity effects Time = 0.5 Courant Number mean: 9.9323e-07 max: 0.00404131 ... Though it is running but i can't plot anything. I am using GNUplot. Also i couldn't understand the line"No finite volume options present". Can anyone explain where i could have gone wrong? Thanks and regards Subhankar


OpenFOAM 13-10-16, 11:39 p.m. SUBHANKAR

Answers:

0

Hello,

I think the simulation is running correctly. There might be some mistake in the file which you are using to create GNUplot.
Regards,
Viraj

19-10-16, 10:52 a.m. virajbelekar

Hi,
Thanks for the reply. I checked the files i used for creating GNUplots with other cases and its running fine. What i can't understand is the message "No MRF models present No finite volume options present Starting time loop forces forces" before running the simulations. I must be doing something wrong.

regards
Subhankar


20-10-16, 10:22 a.m. SUBHANKAR

Hey,


I think you are running your test case without an fvOptions file. That shouldn't be a problem, just ignore the warning.

Regards,
Viraj


20-10-16, 10:45 a.m. virajbelekar

Hey,
Thanks again for the reply. I guess you are right. I have one more problem: whenever i am trying to copy the simulation results to log file using the command "pisoFoam > log" (i am using pisoFoam solver for my case), it isn't writing any of the results into my log file.


21-10-16, 10:28 a.m. SUBHANKAR

Use the following command:
pisoFoam | tee log

The results will be shown in the terminal as well they will be copied in log file


21-10-16, 10:46 a.m. virajbelekar

Hi
I tried your command too. But the problem still persists.


21-10-16, 11:57 a.m. SUBHANKAR

Hi,


Tell me exactly what you are trying to do! Does your simulation work?


21-10-16, 12:10 p.m. virajbelekar

Also upload the content of your log file


21-10-16, 12:12 p.m. virajbelekar

Hi, the files aren't getting uploaded. could you please share your email id. Or you can mail me ( subhankar2020@gmail.com)


21-10-16, 6:01 p.m. SUBHANKAR

Hello Subhankar,


I would like to add one thing:  the content in the terminal cannot be copied to the log file after the simulations are completed. They are copied simultaneously as the iterations proceed. Are you trying to make the log file after the completion of iterations?


24-10-16, 9:51 a.m. virajbelekar

Thanks for the tip. I was trying to make the log file after the completion of iterations. I have one more problem: I am currently solving the same problem but by implementing inlet parabolic(u) boundary condition. I am trying to read from my "u" file that i created but i am unable to do so. I followed the tutorial incompressible/simpleFoam/pitzDailyExptInlet. 


25-10-16, 10:50 p.m. SUBHANKAR

Hi Subhankar,


You can use groovyBC Boundary Condition at inlet to get parabolic velocity. For that, you will have to:
1) download it as instructed here: Download
2) build swak4Foam as instructed here: Building

Carefully set the groovyBC Boundary Condition and you will get it done ;)


26-10-16, 10:27 a.m. virajbelekar

Yes, that i will try. But for now my guide is asking to read the "u" inlet boundary values from a file which i am unable to do so. So can you suggest me any ways?


26-10-16, 10:34 a.m. SUBHANKAR

Also are  there any kind of tutorials or links that may help me using groovyBC boundary conditions? I have never used that (only heard about that). Again thanx a lot for helping me...


26-10-16, 10:40 a.m. SUBHANKAR

1) What do you mean by 'reading from a file'? Do you want to call your BCs from a different file? If this is the case, refer to the motorBike tutorial for simpleFoam solver.


2) Take the help of Google. You will find a lot of material on groovyBC


26-10-16, 10:46 a.m. virajbelekar

Yeah, like i have prepared a u file in the boundaryData folder of the constant folder which has the "u" values of each cell at the inlet face. I calculated those values as per the parabolic variations i wanted to implement.  I followed the tutorial incompressible/simpleFoam/pitzDailyExptInlet.


26-10-16, 10:58 a.m. SUBHANKAR

Hi,


I don't know why you are using the boundaryData folder. If you want parabolic velocity at inlet, you can simply use groovyBC as your inlet boundary condition. Refer to the user guide for syntax of groovyBC


26-10-16, 2:56 p.m. virajbelekar

Login to add comment


Log-in to answer to this question.