0
Not able to setup wifi possibly because sudo does not work

I had bought two laptops. These had two logins "user" and "debian". For some reason the debian login has vanished from one of the laptops.

I am not able to set up wifi. When the ethernet icon is clicked, it shows no networks and shows only the airplan symbol with the click box before.

Sudo command does not work. When I use "sudo -i" in terminal, the response is "sudo must be owned by uid 0 and have the setuid bit set".

Please help to resolve the problem.


Affordable-Laptop 12-09-19, 5:12 p.m. sethbharat
0

It seems you have accidentally changed the ownership/permission of your root(/) filesystem.

Try the following:

  1. Open the terminal of "user" and type
    • su root (passwd: debian)
    • chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
    • reboot and try wifi, try 'sudo -i' etc
  2. If 'root' user isn't available, then try booting into recovery mode by changing the grub (search for it), it will drop you to a root shell, do the above chown and chmod commands
  3. If not, backup your data, and reinstall from our ISO

Let me know if either of these work.

12-09-19, 9:20 p.m. Srikant
The first suggestion doesn't work.

I want to try the second suggestion but would like some help in executing it. Is it possible to give step by step instruction or reference to some article which will tell me how I am to boot the system in recovery mode. When I googled it, there were a number of articles for booting the system to "rescue" mode. However, they say that I have to press "e" in the GRUB screen to enter edit mode. However, I don't seem to be getting the GRUB screen at all . Do I have to do something in /etc/grub.d? or press some function key at boot time?

If you would rather have me try the third suggestion, then please let me know where is the ISO located and instructions for re-installation.

Thanks in advance.


13-09-19, 2:18 p.m. sethbharat
Try the third option from here https://forums.fossee.in/question/858/

15-09-19, 1:07 p.m. Srikant
Hi Srikant,
I managed to make a bootable USB and started the graphical  installation process. It came upto "Detect network hardware" and said that "No Ethernet card was detected. If you now the name of the driver needed by your Ethernet card, you can select it from the list."
Please let me know what driver is to be chosen from the list.
Regards,


18-09-19, 1:09 p.m. sethbharat
Dear Srikant,
I got over the problem by choosing the regular installation process and not graphical one. This time it detected the network hardware properly an reloaded the operating systems.
The Sudo permission etc. got corrected and the Wifi could be set up.

Thanks

19-09-19, 12:11 p.m. sethbharat
Glad it worked!
Thanks for taking your time in updating the correct steps.

20-09-19, 2:05 p.m. Srikant
This seems to have solved my issue. Thanks for your help!

8 ball pool

 


25-02-20, 2:32 p.m. kennywise

Login to add comment


0

You must:

  1. have the sudo package installed.
  2. have “/usr/bin” in your PATH environment variable
  3. You username must be listed with some privileges in /etc/sudoers,or in a file in/etc/sudoers.d/
  4. /etc/sudoers can only be edited with visudo by the superuser, root.
  5. There may be an /etc/sudo.conf file that further refines the capabilities of the sudo command. see man pages.
  6. In almost all cases you will need to enter your personal password when prompted before the command will execute. After that a timeout period starts where you can call sudo commands without re-entering a password for a short period of time.
  7. If you are actually logged in as root, you may or may not be prompted for a password, usually not. Some locked-down systems require a special sudo password to do dangerous things even for root.

-----------------------------------------------

Jitter Speed Test

27-06-20, 1:21 p.m. inigowilson


Log-in to answer to this question.